./configure: error: the HTTP rewrite module requires the PCRE library

(1)安装Nginx时报错

./configure: error: the HTTP rewrite module requires the PCRE library.

解决方法:

yum -y install pcre-devel

(2)安装Nginx时报错

./configure: error: the HTTP gzip module requires the zlib library.

解决方法:

yum -y install zlib-devel

(3)安装Nginx时报错

./configure: error: the HTTP cache module requires md5 functions

from OpenSSL library.   You can either disable the module by using

--without-http-cache option, or install the OpenSSL library into the system,

or build the OpenSSL library statically from the source with nginx by using

--with-http_ssl_module --with-openssl=<path> options.

解决方法:

yum -y install openssl openssl-devel



by 雪洁 2013-03-20 03:04:07 6593 views
我来说几句

相关文章